The license is not active: Diffblue Cover requires an active internet connection with access to https://licensing.diffblue.com, and https://api.licensespring.com to authorize use of the plugin

When i try to create a test just show

The license is not active: Diffblue Cover requires an active internet connection with access to https://licensing.diffblue.com, and https://api.licensespring.com to authorize use of the plugin. We cannot access one or more of theses servers. This may be due to lack of an internet connection, or a firewall, or there are some other security mechanisms blocking this connection. See Network connections | Diffblue Docs for more detailed information on troubleshooting this issue. Otherwise please contact Support | Diffblue

.My connection is fine, and i dont have firewall… somebody could help me please?

Hi @leo,

Thanks for getting in touch - I am sorry that you are facing this issue; we will try and help you to get it resolved ASAP

Could I start by asking if you are on a corporate network or VPN or are you on a normal home internet connection?

Secondly please could you ping licensing.diffblue.com

And finally are you able to directly access https://api.licensespring.com/ (you should see a message that says “no one is home”)

Thank you once again for getting in touch - we will try and get you up and running

Kind Regards

Matthew
Diffblue

Hi @Matt,
Thanks for your time!

C:\Users\leo>ping licensing.diffblue.com

Haciendo ping a part-0005.t-0009.t-msedge.net [13.107.213.33] con 32 bytes de datos:
Respuesta desde 13.107.213.33: bytes=32 tiempo=80ms TTL=121
Respuesta desde 13.107.213.33: bytes=32 tiempo=42ms TTL=121
Respuesta desde 13.107.213.33: bytes=32 tiempo=138ms TTL=121
Respuesta desde 13.107.213.33: bytes=32 tiempo=46ms TTL=121

Thanks @leo for your quick response!

From what you tell me it seems not to be a network issue - please could you try the following steps?

  • If you haven’t tried so already please could you restart IntelliJ and try again
  • Please could you check for the presence of the file license.key approximately 3KB in size; this will be at the location ~/.diffblue/license.key on Linux/Mac or in C:\Users\<username>\.diffblue\license.key on Windows 10
  • Please could you let me know what version of Java you have configured in IntelliJ?

Thank you for your patience

Matthew
Diffblue

@Matt That’s very kind of you

  • I tried restarting intelliJ, but it still
  • license.key is not present
  • I use java version “11.0.11” 2021-04-20 LTS

Thanks for trying that @leo. Are you running any kind of anti-virus, malware detector or firewall software on your computer? If so, it may be worth temporarily disabling those and then try restarting IntelliJ and creating tests again.

Hi @chrryd, thanks for responding!
I’m not running any kind of antivirus :frowning:
Tried stopping everything (like windows firewall or defender) but it’s still the same.

Thanks for confirming that @leo. Could I please ask you to check the SSL certificate on https://api.licensespring.com/ and https://licensing.diffblue.com/ and tell us what the certificate details are? a screenshot would be great, but we are especially interested in the certificate fingerprint. There are some good instructions on how to do this for various common browsers here: How to View SSL Certificate Details in Chrome, Firefox, IE, Microsoft Edge, and Vivaldi

Thanks again for your help with this, and for your patience,
Chris.

@chrryd thanks a lot for your help! Of course i send you the screemshoots



thanks in advance for your help

Many thanks @leo we really appreciate your persistence on this! On each of those certificate dialog boxes, could you click on the ‘Detalles’ tabs, and scroll down through the list of fields and show us what the value of the “Thumbprint” field is? We just want to check that the correct servers are being contacted, and that there isn’t some sort of ISP transparent proxy in the way.

Thanks for responding, I really appreciate your help!


Many thanks for the super-speedy response @leo - very helpful. That seems to confirm that the correct servers are being contacted, so there must be something else going on. I’m going to consult a bit more with the folks who worked on the new licensing integration work, and with our server admins, and we’ll get back to you ASAP…

Thanks a lot @chrryd ! I will pending on your response

@chrryd hello! I have done other tests (on a partner’s computer) and the result is the same, maybe this data will help you.
Another topic that we see (maybe this is ok) when we enter https://licensing.diffblue.com/ we are always redirected to https://www.diffblue.com/
Thanks in advance!

Thanks for the extra experiment and information @leo - much appreciated! We’re still trying to reproduce this issue in our test environments, and we’re also going to be adding a lot of extra logging to help debug this further. I’m not yet sure which release the extra logging will be delivered in, but I (or someone else on the team) will get back to you on Monday with an update. We’re sorry for the problems here, but we’re really keen to get to the bottom of this and solve it for you.

1 Like

hi, i am having the same problem.
I installed the plugin and when trying to write the first test it gives a license error.

I would appreciate if you can tell me what to do to make it work
thanks in advance.
Pablo

Hi Pablo, we plan to make a release with extra logging on shortly. We would be grateful if you could try that let us know the results - the logfile should give a good indication of what is going wrong.
Regards
Andy

Hi @Leo and @pdamonte,

There’s a new version of the plugin available on the JetBrains market place. Can you update and restart the IDE? It’ll produce a log file (Log file | Diffblue Docs) that you can share with us and allow us to diagnose what’s going on.

Out of interest, what java version are you using for your projects?

Thanks for helping us trouble shoot this issue once we have the log files we’ll see what we can do to fix the issue.

Regards,
Paul

1 Like

Hello @paul_crane
It’s working for me! License.key has been generated and the tests are being writing
Thanks a lot to all the diffblue staff for your time and quick response
java version: 11.0.11
If you need anything else let me know.
Thanks for your attention!

I’m having a similar experience.

IntelliJ plugin version: Diffblue Cover 2021.10.02-licensed.2021.2

No ~/.diffblue/license.key
URLs look good.

ping licensing.diffblue.com
PING part-0010.t-0009.fb-t-msedge.net (13.107.253.38): 56 data bytes
64 bytes from 13.107.253.38: icmp_seq=0 ttl=118 time=16.006 ms
64 bytes from 13.107.253.38: icmp_seq=1 ttl=118 time=17.286 ms
64 bytes from 13.107.253.38: icmp_seq=2 ttl=118 time=23.627 ms

Directly access to https://api.licensespring.com/ is ok (show “no one is home” )

Java 1.8.0_291